Z3 Idle problems and others

The BMW Z3 was BMW's first mass produced mass market roadster. E36/7 refers to the roadster variant of the Z3 which was introduced in 1995, and E36/8 refers to the coupe variant of the Z3 which was released in 1999.

Moderators: synergy, kyleabaker

galkollajp
n00b-1st Gear
n00b-1st Gear
Posts: 1
Joined: Sat Nov 15, 2008 12:43 pm

Z3 Idle problems and others

Post by galkollajp » Sat Nov 15, 2008 5:29 pm

Hello Bimmers!I m kinda new here.
I have a 98yr Z3 1.9(M44 engine) which has done around 110k kms.Haven't had any problem until this rough idle thing.
1.the idle rpm is stable(around 800),but if i raise the rpm to around 1000 and let it drop back to idle,it starts to vibrate noticeably.(especially at traffic lights)
2.After the engine runs for a while after startup,i get this strange tapping sound from the lower part of engine on the air intake side.It is accompanied by the sound of pressurised air trying to escape from somewhere .It stops after a while.could it probably be some stuck valve or a pump?
3.Sometimes i get a faint smell of gas while driving.(vacuum leak?)
4.i have cleaned the ICV,with no positive results.
5.i dont feel any vibrations or misfires at higher RPMs.

whats the closest guess to start with?and please be kind to give any links with images if possible.
i dont want to replace every part at once,(like the BMW service guys said)!
Edit/Delete Message

User avatar
kyleabaker
Site Admin
Site Admin
Posts: 386
Joined: Tue Jan 17, 2006 10:40 pm
Location: 28777 and/or 27605

Re: Z3 Idle problems and others

Post by kyleabaker » Tue Dec 02, 2008 5:51 am

galkollajp wrote:Hello Bimmers!I m kinda new here.
I have a 98yr Z3 1.9(M44 engine) which has done around 110k kms.Haven't had any problem until this rough idle thing.
1.the idle rpm is stable(around 800),but if i raise the rpm to around 1000 and let it drop back to idle,it starts to vibrate noticeably.(especially at traffic lights)
2.After the engine runs for a while after startup,i get this strange tapping sound from the lower part of engine on the air intake side.It is accompanied by the sound of pressurised air trying to escape from somewhere .It stops after a while.could it probably be some stuck valve or a pump?
3.Sometimes i get a faint smell of gas while driving.(vacuum leak?)
4.i have cleaned the ICV,with no positive results.
5.i dont feel any vibrations or misfires at higher RPMs.

whats the closest guess to start with?and please be kind to give any links with images if possible.
i dont want to replace every part at once,(like the BMW service guys said)!
Edit/Delete Message
That sounds like a vacuum leak to me. I had a small problem with that on my car a few years ago and it ended up being a small hose that was soaked from oil or something and became soft. It must have been pinched and get a small tear or hole in it. After fixing that, my car idles fine now.

The ticking noise is a common problem. I'm not exactly sure what it's caused from, but possible an oil change with a different type or brand might fix the ticking.
Image

Who is online

Users browsing this forum: CommonCrawl [Bot] and 0 guests